So you need to upgrade from 10.04 to 10.10, and only then to 11.04. When a new version of an existing package is installed it sometimes has to perform conversions, e.g., it may have to import existing settings into a new database format.In performing such conversions the packaging scripts have to make assumptions about the old format.

Upgrading directly from the penultimate, or earlier, version to the current version (called a "skip upgrade) is possible, but is liable to result in a misconfigured system.

Do you know of an official statement from Canonical/Ubuntu on this subject?

Seems strange to me that they don't officially support this.

Otherwise, why would the update-manager from Ubuntu 12.10 even give me the option to only upgrade to LTS releases if that will never be a possibility?

I've done : $ sudo gem install --local rubygems-update getting: Successfully installed rubygems-update-1.1.1 1 gem installed however: $ gem --version 1.1.0 same result if the attempt made with remotely available gem what's wrong ?

-- Une BĂ©vue gem --version 1.1.0 also i should mention when installing wx Ruby i didn't got the lastest version.i had to uninstall it, download the gem to a local rep and do the install locally : $ gem install --local wx Ruby being in the gems local repository it's a known prob from wx Ruby mailing list...Ubuntu only supports upgrading from one version to the next version, or from one LTS version to the next LTS version.To update from an older version (very old in this case) than the previous version to the current version is highly not recommended.You are better off downloading the new release, doing a backup and then installing the new release.If you are using Ubuntu 10.04 and REALLY REALLY want to update from that version up to the latest version then keep reading, if you are using Ubuntu 10.10 and also want to update from that version up to the latest version go to the second part.